Systemedge agent service fails to start with the error: "Failed to initialize file-based configuration module: [1] CAM has shutdown"

Document ID:  TEC1124427
Last Modified Date:  12/23/2015
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Products

  • CA SystemEDGE
  • Unicenter Message Queuing Server (CAM)

Releases

  • CA SystemEDGE:Release:5.8
  • CA SystemEDGE:Release:5.9

Components

  • SYSTEM EDGE CORE AGENT:SEAGT
  • CCSCAM - MESSAGE QUEUING:CCSCAM

Problem: 

If you try to start SystemEDGE service with no success, and the following errors appear in SystemEDGE logs:

[A]-012478-f771d6c0- se/sysedge_init.c[856]       : initialize_agent(): **** CA SystemEDGE (Version 5.7.1 Build 13002)
[A]-012478-f771d6c0- se/sysedge_init.c[857]       : initialize_agent(): **** Copyright 2013 by CA, Inc
[A]-012478-f771d6c0- se/sysedge_init.c[858]       : initialize_agent(): **** Installed at '/opt/CA/SystemEDGE'
[A]-012478-f771d6c0- se/sysedge_init.c[860]       : initialize_agent(): **** Running in managed mode (managed by 'xxx.xxx.xxx.xxx')
[A]-012478-f771d6c0- se/sysedge_init.c[871]       : initialize_agent(): **** Using port 1691
[A]-012478-f771d6c0- se/cfsyswrapper.c[1193]    : cf_Init(): SystemEDGE is running in managed mode, manager is 'xxx.xxx.xxx.xxx'
[I]-012478-f771d6c0- caismcomm/config_handler.c[2508]: CfSys_Init(): Cannot connect to CAM yet - Unable to connect to CAM server
[F]-012478-f771d6c0- se/cfsyswrapper.c[1297]     : cf_Init(): Failed to initialize file-based configuration module: [1] CAM has shutdown
[A]-012478-f771d6c0- se/cfsyswrapper.c[1370]     : cf_Init(): Unable to support file-based configuration
[F]-012478-f771d6c0- se/sysedge_init.c[880]        : initialize_agent(): Failed to initialize agent/manager communication module
[F]-012478-f771d6c0- se/sysedge.c[312]              : main(): Failed to initialize agent

You check the CAM logs and the following errors appear too:

Starting CAM version 1.13 (Build 10_8)
no port defined for service "camudp", using default
no port defined for service "camtcp", using default
localhost didn't resolve to an IPv6 address.  Adding ::1
Local hostname is >xxxxxx<
Local address is >xxx.xxx.xxx.xxx<
UDP port is 4104
TCP port is 4105
bind() failed in init_listen with ai->ai_addr = 0.0.0.0:4104: socket error (98) Address already in use
bind() failed in init_listen with ai->ai_addr = [::]:4104: socket error (98) Address already in use
UDP port unavailable
CAM error: unable to bind to port (CAM probably already running) - (98) Address already in use

Environment: 

CA SystemEdge 5.x

Cause: 

When SystemEDGE is configured to run in Managed Mode (considering it is being managed by CA VAIM ), it depends on CAM to work properly. In this scenario, there is a problem with CAM (bind error/port in use) and it is preventing SystemEDGE service to start.

Resolution:

CAM is used for VAIM agent registration and policy deployment.  If there is no VAIM manager used you can  put the agent into unmanaged mode, then CAM is no longer needed as SystemEDGE configuration is done by snmp .

You can disable Managed Mode temporarily (until the CAM problem to be solved), or definitely (if Managed Mode is not necessary).

Please follow the procedures below:

a-) Stop SystemEDGE service:

if Unix/linux -> Open a command line and Issue "/opt/CA/SystemEDGE/bin/sysedgectl stop" command.
if Windows -> Click on "stop agent" button in SystemEDGE Control Panel.


b-) Switch SystemEDGE to non-managed mode:

- Open SystemEDGE\config\sysedge.cf

- Comment out or remove the following line:

   "manager_name"

- Save the file.

- Open SystemEDGE\data\<port_number>\sysedge.cf

- Comment out or remove the following 3 lines:

    "manager_name"
    "manager_policy_name"
    "manager_policy_version"

- Save the file.

c-) Start SystemEDGE service:

if Unix/linux -> Open a command line and Issue "/opt/CA/SystemEDGE/bin/sysedgectl start" command.
if Windows -> Click on "start agent" button in SystemEDGE Control Panel.

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