How do I Configure a CAF plugin to run with a different account instead of the default Local System Account?

Document ID:  TEC466388
Last Modified Date:  07/09/2017
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Products

  • CA Client Automation
  • CA IT Client Manager
  • CA Server Automation

Releases

  • CA Client Automation:Release:12.9
  • CA Client Automation:Release:12.8
  • CA Client Automation:Release:14.0
  • CA Client Automation:Release:14.0 SP1

Components

  • DESKTOP AND SERVER MANAGEMENT:DTSVMG
  • CA Client Automation:BITCM
Problem:

In certain secure environments, the Local System Account may be restricted or have limited privileges.

The CAF plugin is configured to run with the Local System Account by default and therefore will not run in such environments. In such cases, the CAF plugins can be configured to use a different account.

Environment:
All supported Windows Operating Systems CA Client Automation?- All versions
Cause:

The CAF Service (all plugins) runs using the Local System Account by default which may cause issues related to permissions when running software jobs requiring administrator permissions.

This document outlines how a CAF plugin (Software Delivery plugin in this case) can be configured to run with specific administrator credentials.

Resolution:

The following command is used to configure a CAF plugin to use different account:

caf setcreds <plugin> user <username> password <password>

Example: caf setcreds sdagent user administrator password abc12345!

**Note: In the above example "abc12345!" is the administrator password.

 

To backout the changes and set the plugin back to using the Local System Account,  you run the same command with no Username and Password

caf setcreds <plugin> 

Example: caf setcreds sdagent 

This will set the SDAgent to Run as Local System Account

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