CA TPX is failing with TPX052 INITIALIZATION ERR: SMRT SMRTTEST NOT LOADED

Document ID:  TEC448128
Last Modified Date:  12/29/2017
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Products

  • CA TPX Session Management for z/OS

Releases

  • CA TPX Session Management for z/OS:Release:5.3
  • CA TPX Session Management for z/OS:Release:5.4

Components

  • CA-TPX for OS/390:TPX
Issue:

CA TPX is failing with message: 

TPX052 INITIALIZATION ERR: SMRT SMRTTEST NOT LOADED

Environment:
CA TPX for z/OS
Cause:

TPX052 indicates that the specified table was not found in the ADMIN files.

  • If the SMRT or ACT tables are not found, the product abends with S000 U0001 REASON=00000000.

  • Otherwise, it continues running without the table.

As part of the TPX install process, sample data is loaded into ADMIN1 and ADMIN2. This includes a SMRT (Session Manager Resource Table) called SMRTTEST and an ACT (Application Characteristics Table) called ACTTEST.

So when you get TPX052 for SMRT SMRTTEST, the most likely cause is that the load step for these tables was omitted when TPX was installed or SMRTTEST has been deleted.

Resolution:

CB0VJCL(DEFVSAM) should be executed during the install process.  This job will define and initialize the five TPX VSAM files with delivered data from CB0VDATV that includes SMRTTEST, ACTTEST and userid TPXADMIN among other things.

 

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