Deployment Fails with Error "pre init timeout (180 seconds) expired."

Document ID:  TEC1952797
Last Modified Date:  08/10/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Release Automation

Releases

  • CA Release Automation:Release:6.2
  • CA Release Automation:Release:5.0
  • CA Release Automation:Release:5.0.1
  • CA Release Automation:Release:5.0.2
  • CA Release Automation:Release:5.5
  • CA Release Automation:Release:5.5.1
  • CA Release Automation:Release:5.5.2
  • CA Release Automation:Release:6.0
  • CA Release Automation:Release:6.1
  • CA Release Automation:Release:6.3

Components

  • CA LISA RELEASE AUTOMATION CORE:RACORE
  • RELEASE AUTOMATION AGENT:RAAGT
  • RELEASE AUTOMATION EXECUTION SERVER:RAEXS
Problem:

A deployment enters into a "Failed - Paused" status due to failing at the Pre-Plan Step.  The following error is then found in the nolio_dm_all.log:

 

[http-nio-443-exec-18] ERROR (com.nolio.releasecenter.controllers.RCApiController:1873) - RC API Controller method error occurred.

com.nolio.releasecenter.cli.CliServerException: Deployment Plan with id [xxxx] was created. pre init timeout (180 seconds) expired. Status of pre init stage: [Failed-paused]

Cause:

An action associated with the Pre-Plan Step either failed or did not complete within the pre-init timeout of 180 seconds. 

Resolution:

Identify which action resulted in the timeout. The easiest way identify what caused the timeout is via the following steps:

  1. Login to Release Operations Center (ROC)
  2. Navigate to Environments --> Process Execution.
  3. Select the process that was used as the Pre-Plan Step.
  4. The action which failed to complete within the timeout will be highlighted. 

Once the action is identified, note that the action would have exceeded the timeout if it (a) failed completely or (b) did not necessarily fail, but did not complete running within the 180 second timeout. 

If the action failed, correct the action as needed.  If the action would not have failed but nonetheless exceeded the timeout, then consider moving the action or process to another stage, such as to a Deployment Step.

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