Max % Load is not exporting to the MSP New Driver when Windows regional setting is not English

Document ID:  TEC1897338
Last Modified Date:  10/19/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA PPM

Releases

  • CA PPM:Release:15.1
  • CA PPM:Release:15.2
  • CA PPM:Release:15.3

Components

  • CLARITY ON DEMAND INVSTMNTS, PRJCTS, RESOURCES & NPIO MGMT:ODINCL
  • CA PPM SAAS MICROSOFT PROJECT (MSP) INTERNAL ONLY:ODMSP
  • CLARITY PPM INVSTMNTS, PRJCTS, RESOURCES & NPIO MANAGEMENT:PPMINV
  • CA PPM MICROSOFT PROJECT (MSP)INTERNAL ONLY:PPMMSP
Problem:

Even though MSP Assignment Units Mapping with PPM Assignment 'Max % Load' is checked in PPM, Max % Load is not exporting to Microsoft Project (MSP) when Windows regional setting is not set to English. 

Steps to Reproduce

Prerequisites:

  • Non English MSP2013 SP1 (Example: Portuguese or Spanish) with a supported Microsoft Project Update
  • Windows language: English with non English Regional setting (Example: Portuguese or Spanish)
  1. Go Administration -> Project Management->Settings 
  2. Check 'MSP Assignment Units Mapping with PPM Assignment 'Max % Load'' 
  3. Save the change
  4. Go to Home -> Projects and create a new project
  5. Add one team member to the project
  6. Create a task and assign the resource to the task
  7. Change the Max % Load of the assignment to 50%
  8. Export the project to MSP
  9. Double click on the task and view the Units for the Assignment

Expected Results: Units matches the Max % Load set for the assignment (in this example, 50%).

Actual Results: Units doesn't reflect the 'Max % Load' for the assignment (it will show as 0% regardless of what is set on the PPM side) as the Max % Load does value is not exported to MSP.

Environment:
This issue applies to Microsoft Project 2013 with 14.4, 15.1, and 15.2, and 15.3 MSP New Driver
Cause:

This is caused by DE33331

Resolution:

For 15.1, this issue is fixed in 15.1 patch 8. For all other impacted releases, this issue is still under investigation.

Note: Once this issue is fixed, the latest supported Microsoft Project update must also be installed in order to reflect the fix, as a related MSP  defect was fixed in the Microsoft Project July 2017 update (MSP2013: KB3213538 and MSP2016: KB3203476). 

Workaround: 

Change the OS level setting of 'Decimal symbol from comma ',' to period '.'

Steps to implement the workaround:
  • Go to Control Panel->Region->
  • Click the 'Additional Settings' button
  • Change Decimal symbol value to '.'
Additional Information:

Reference TEC1830355 for more information on supported Microsoft Project updates with the MSP New Driver

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >