Unable to set Web Client Alarms preference greater than 50,000

Document ID:  TEC1863461
Last Modified Date:  08/04/2017
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Products

  • CA Spectrum

Releases

  • CA Spectrum:Release:10.0
  • CA Spectrum:Release:10.1
  • CA Spectrum:Release:10.2
  • CA Spectrum:Release:10.2.1

Components

  • ONECLICK:SPCOCK
Issue:

In a large Distributed SpectroSERVER (DSS) environment where there are over 50,000 total alarms, users are unable to set the Web Client Alarms preference to a value greater than 50,000.

Max_Web_Alarms_1.png

Cause:

This is functioning as designed. The Web Client UI enforces a max value of 50,000 for the Alarms preference.

Workaround:

The 50,000 max value for the Web Client Alarms preference can be manually overwritten by editing the WebclientUserPreferences attribute id 0x13341 on the User model in the Spectrum database by doing the following:

1. Use the OneClick Locater to find and select the User model. In a DSS env, choose the User model from the MLS server. Aftef making the change to the User model on the MLS server, the changes will be propagated to the other User models in the DSS.

2. Click on Attributes tab in the Component Detail panel

3. Find and select the WebclientUserPreferences attribute id 0x13341

4. Edit the value. Look for the current value for alarms and change to the value needed. Please see the following example:

Max_Web_Alarms_2.png

5. Save the change

6. Log into the Web Client and verify the new value.

Max_Web_Alarms_3.png

Additional Information:

NOTE: Manually increasing the value of the Web Client Alarms preference can cause undesirable performance issues with the Web Client.

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