When trying to change values in an SNMP profile on the Data Aggregator via REST, a '403 Forbidden' error is returned

Document ID:  TEC1849414
Last Modified Date:  08/08/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Performance Management

Releases

  • CA Performance Management:Release:3.2
  • CA Performance Management:Release:3.1
  • CA Performance Management:Release:3.0
  • CA Performance Management:Release:2.8
  • CA Performance Management:Release:2.7.0
  • CA Performance Management:Release:2.6
  • CA Performance Management:Release:2.5

Components

  • IM DATA AGGREGATOR:IMAGGR
Issue:

When trying to change values in an SNMP profile located on the Data Aggregator,  through a REST client, using a PUT call such as the following:

http://<DA_HOST>:8581/rest/profiles/<profile_item_id> 

Body of the PUT request:

<?xml version="1.0" encoding="UTF-8"?> 
<CommunicationProfile version="1.0.0"
<CommunicationFailurePolicy version="1.0.0"
<Timeout>timeout in sec (e.g.:3000)</Timeout> 
<Retries>Number of retries (e.g.:4)</Retries> 
</CommunicationFailurePolicy> 
</CommunicationProfile>

An Status Code: 403 Forbidden error occurs.

Environment:
CAPM 3.x
Cause:

The SNMP profile is tied to a tenant other than the default tenant you are trying to modify, so the operation isn't supported (for this tenant ID). Hence, the appropriate TenantID to which the profile is attached must be specified as well as the ProfileID in the REST call

Resolution:

For the REST PUT call, the URL should be of the format:  

http://<DA_HOST>:8581/rest/tenant/TENANTITEMID/profiles/PROFILEID

Where TENANTITEMID and PROFILEID are the respective ID values for the tenant and the profile to which it is attached. Get TENANTITEMID using: 

http://<DA_HOST>:8581/rest/tenants 

 

And find the ID of the tenant the SNMP profile is in.

 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >