APM WebView/ATC slow login with Active Directory/EEM/SiteMinder.

Document ID:  TEC1822827
Last Modified Date:  08/09/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Application Performance Management

Releases

  • CA Application Performance Management:Release:10.5.1

Components

  • Integrations with other Products:APMITG
Problem:

 When connecting to APM Team Center using EEM/LDAP/Siteminder users, the login takes 90 seconds instead of 2 seconds seen by local users .

This problem appeared with the 10.5.1 version.

 The login is faster with prior APM Team Center versions . 

 

 

Environment:
Linux , APM 10.5.1
Cause:

 Some changes in the 10.5.1 login processing checking all objects owned by one user .

Resolution:

Install the 10.5.1. HF 21 patch :

10.5.1 HF 21 contains caching of EEM data on APM side. The first login might take 20 seconds because APM is fetching data for that user. The second and following logins are using the new cache and the speed of the login should be same as it used to be before 10.5. 


Once user is logged in for the first time, the cache is periodically on background updating the users authorization data from EEM/LDAP to have them up to date. 

Additional Information:

https://support.ca.com/us/knowledge-base-articles.TEC1566066.html  -- CA APM Webview takes too long to login for LDAP users who belong to Nested Group.

 

 

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