Deployment Blocked by Another Deployment

Document ID:  TEC1737936
Last Modified Date:  07/06/2017
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Products

  • CA Release Automation

Releases

  • CA Release Automation:Release:5.0
  • CA Release Automation:Release:5.0.1
  • CA Release Automation:Release:5.0.2
  • CA Release Automation:Release:5.5
  • CA Release Automation:Release:5.5.1
  • CA Release Automation:Release:5.5.2
  • CA Release Automation:Release:6.0
  • CA Release Automation:Release:6.1
  • CA Release Automation:Release:6.2
  • CA Release Automation:Release:6.3

Components

  • CA LISA RELEASE AUTOMATION CORE:RACORE
  • RELEASE AUTOMATION EXECUTION SERVER:RAEXS
Problem:

This problem may manifest in one of two ways:

  • A deployment hangs with a "blocked" status.
  • A deployment runs indefinitely, showing no sign of progress or failure, and may block other deployments waiting for it to finish. 
Cause:

Root cause behind an indefinite hang can vary, but if a deployment is specifically blocked, it is likely because a previous deployment is in a "Fail-Paused" state.

Common causes include a failure during artifact distribution or an agent required by the deployment going offline.  

Resolution:

Depending on how the process in question was being executed, there are two possible solutions for force-killing the process. If one method does not resolve the problem, try the other.

Solution 1: noliocenter

  1. Navigate to JMX (http://<NAC hostname>:20203).
  2. Login with username/password nolio/nolio.
  3. Scroll down to the section "Domain: noliocenter".
  4. Select "noliocenter:type=info".
  5. Click the "Invoke" button to the right of "listActiveRuns".
  6. Find the ID of the hung process.
  7. Go back to the previous page.
  8. In the field to the right of "removeProcessRun", enter the ID of the hung process.
  9. Click the "Invoke" button on the same row (for "removeProcessRun").

Solution 2: releasecenter

  1. Navigate to JMX (http://<NAC hostname>:20203).
  2. Login with username/password nolio/nolio.
  3. Scroll down to the section "Domain: releasecenter".
  4. Select "releasecenter:type=Info".
  5. Click the "Invoke" button to the right of "getAllActiveReleases".
  6. Find the ID of the hung process.
  7. Go back to the previous page.
  8. In the field to the right of "removeRelease", enter the ID of the hung process.
  9. Click the "Invoke" button on the same row (for "removeRelease").
Additional Information:

The reason there are two different but very similar solutions is because there is more than one way to run a specific process.  A process may have been running as a test run prior to publishing, or it may be running as part of a published deployment, for example.

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