The pdm_settenant command is failing to complete.

Document ID:  TEC1697948
Last Modified Date:  06/08/2017
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Products

  • CA Service Desk Manager

Releases

  • CA Service Desk Manager:Release:14.1
  • CA Service Desk Manager:Release:12.9 CA SDM
  • CA Service Desk Manager:Release:17.0

Components

  • UNICENTER SERVICE DESK RXX:USRD
Issue:

The pdm_settenant command is failing to complete. When checking the stdlog the following error is logged:

ERROR set_tenant_mgr.c 307 received message got_row_and_tenant_id with error: AHD03200:Fetch is complete

Environment:
SDM 12.9 SDM 14.1 SDM 17
Cause:

By default the "fetch size" for pdm_settenant is set to 500.

In the example above the fetch size was set to a value greater than 500.

Resolution:

In addition to the pdm_settenant command enter "-s fetch_size" to specify the fetch size for fetching data from a table specified in the configuration file.

The fetch size can be a value between 100 and 1000, however cannot be greater than 1000.

Additional Information:

If the fetch size is over 1000, the settenant.xml file can be modified by adding in an additional Where clause to lower the fetch size below 1000.

See TEC1795197 below for instruction on how to add an additional where clause to set tenancy based on group:

https://support.ca.com/us/knowledge-base-articles.tec1795197.html

 

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