Autoprobe logs are growing to huge sizes.

Document ID:  TEC1622313
Last Modified Date:  08/03/2017
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Products

  • CA Application Performance Management

Releases

  • CA Application Performance Management:Release:10.1
  • CA Application Performance Management:Release:10.2
  • CA Application Performance Management:Release:10.3
  • CA Application Performance Management:Release:10.0

Components

  • APM AGENTS:APMAGT
Issue:

 Java Agent produces huge autoprobe log files, ranging into gigabytes in size.

Environment:
Java Agent, 9.7 and above.
Cause:

Huge Autoprobe logs can be caused by dynamic instrumentation being triggering excessively, resulting in frequent re-instrumentation. (This also means quick growth of the autoprobe.log files which records the re-instrumentation.)

Resolution:

Simply disabling the autoprobe.log is not recommended, as the underlying re-instrumentation will continue. Instead for cases where this occurs, the following should be changed in the agent profile (IntroscopeAgent.profile):

 

introscope.autoprobe.dynamicinstrument.enabled=false

introscope.autoprobe.deepinheritance.enabled=false

introscope.agent.deep.entrypoint.enabled=false

 

 The application should be restarted for these changes to take effect.

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