After applying HotFix HF10 on top of CA 4.2.2 and restarted Process Automation, getting below error message in C2O log: Operand type clash: nvarchar is incompatible Which results in Ca Service Catalog requests not launching instances.

Document ID:  TEC1587778
Last Modified Date:  08/09/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Process Automation

Releases

  • CA Process Automation:Release:4.2.2
Issue:

After applying HotFix HF10 on top of PA 4.2.2 and restarted Process Automation, getting below error message in C2O log:

: java.lang.Throwable: java.sql.BatchUpdateException: Operand type clash: nvarchar is incompatible with image at net.sourceforge.jtds.jdbc.JtdsStatement.executeBatch(JtdsStatement.java:1069) 

Due to this, CAService catalog requests are not being received by Process Auto.

Cause:

DB user doesn't have the DBO(Database Owner) permission while starting the PAM after applying this HotFix.

 

Resolution:

Please provide DBO permission to DB user for PAM.

HotFix HF10 contains DB schema changes related to ActiveMQ which got upgraded to latest version through this hotfix.

So, PAM must have DBO permission while starting the PAM after applying this HotFix.

Additional Information:

DBO(Database Owner) permissions are required whenever we upgrade OR apply any patch which involves DB Schema changes.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >