Upgrading a new SAM server. Unable to apply the SAMImportExport.exe from the APM 12.9, C4 patch.

Document ID:  TEC1580344
Last Modified Date:  08/07/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA IT Asset Manager
  • CA Software Asset Manager

Releases

  • CA IT Asset Manager:Release:12.9
  • CA Software Asset Manager:Release:12.9

Components

  • CA SOFTWARE ASSET MANAGER:CASAM
  • CA Asset Portfolio Management:ARGIS
Issue:

We are upgrading CA Asset Portfolio Management to C4 and upgrading CA Software Asset Manager to 4.2.2. 

When we run the SAMImportExport.exe on the SAM server, it errors with: The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program.

 

Environment:
CA Software Asset Manager, any version CA Asset Portfolio Management, 12.x releases
Cause:

The SAMImportExport.exe is a patch upgrade, not a full install.  The SAM server did not have a prior version of the SamImportExport service installed. 

Resolution:

Install the SAMImportExport service from the original APM 12.9 DVD media.   The .msi installer for this service is in the \SAMImportExport directory of the APM 12.9 DVD media. 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >