MSP New Driver: Task Durations are incorrect if the PPM Base Calendar is not set to 8 hour days

Document ID:  TEC1518734
Last Modified Date:  07/07/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA PPM

Releases

  • CA PPM:Release:14.3
  • CA PPM:Release:14.3 On Demand
  • CA PPM:Release:14.3 On Premise
  • CA PPM:Release:14.2
  • CA PPM:Release:14.2 On Demand
  • CA PPM:Release:14.2 On Premise
  • CA PPM:Release:14.4
  • CA PPM:Release:15.1

Components

  • CLARITY HOSTED INVSTMNTS, PRJCTS, RESOURCES & NPIO MGMT:HINVCL
  • CLARITY ON DEMAND INVSTMNTS, PRJCTS, RESOURCES & NPIO MGMT:ODINCL
  • CLARITY PPM INVSTMNTS, PRJCTS, RESOURCES & NPIO MANAGEMENT:PPMINV
Problem:

Problem:

When opening a project in the Microsoft Project (MSP) New Driver, task durations are exported incorrectly if the base calendar is not set to 8 hour per day shifts. 

Steps to Reproduce:

  1. Launch MSP stand alone, close all opened projects including "Project 1", go to Options > Schedule > set 'Hours per day' to 7 hours and 'Hours per week' to 35
  2. Close MSP
  3. Set the PPM Base calendar to 7.5 hours per day:
    • Log in to CA PPM > Administration > Project Management > Base Calendars > locate the site calendar marked as "Base calendar"
    • Go to "Edit Calendar Exception" tab
    • Select all weekdays by clicking on the checkbox on the weekday columns: Mon, Tue, Wed, Thu, Fri
    • Click 'Set Shifts'
    • Change the shifts so that there are 7 hours for a day. For instance, set the first shift to start from 8:30 AM instead of 8 AM
    • Save and Return
  4. Create a project in PPM 
  5. Create a one day task on the project 
  6. Open the project in MSP

Expected Result:  Task has a 1 day duration matching PPM

Actual Result: Task has a duration of 1.07, finishing at 9AM the following day

Environment:
This issues applies to CA PPM 14.x and higher in the?MSP New Driver
Cause:

This issue is caused by CLRT-79717/DE33790  

 

 

Resolution:

In CA PPM 15.1, this has been fixed in 15.1 patch 6. For all other impacted releases, this issue is still under investigation as DE33790

Workaround:

1. Adjust the task duration to match that of CA PPM before saving from MSP

OR

2. Add a dummy assignment to any tasks without assignments

OR

3. Use the MSP Legacy Driver

Additional Information:

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