Unable to post messages on agent side

Document ID:  TEC1471641
Last Modified Date:  08/01/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Process Automation

Releases

  • CA Process Automation:Release:4.3.1

Components

  • Process Automation:ITPAM
Issue:

Problem: we are using the "Invoke Java" Operator on a Process Automation Agent. Basically, this is working fine. But unfortunately, only after a freh restart of the Process Automation Agent of the target node. A second attempt will fail with "Message could not be posted to the node"-error. After killing the agent and restarting it, it works fine again - for exactly a singe process execution. 

Environment:
agent logs ************* 2017-07-21 14:43:52,244 ERROR [com.optinuity.c2o.util.SimpleCastorXMLUtil] [A Agent Startup] Mapping File serviceOperationMappingFilenot Found. This may be available at GUI or Source. 2017-07-21 14:43:52,245 ERROR [com.optinuity.c2o.util.SimpleCastorXMLUtil] [A Agent Startup] SimpleCastorXMLUtil.getMapping: failed to find mapping serviceOperationMappingFile file: serviceOperationMappingFile 2017-07-21 14:43:56,658 WARN [com.optinuity.c2o.util.SSLCertificateUtilities] [A Agent Startup] Setup to accept all SSL Certificates Removing / Reinstalling the agent did not help
Resolution:

Above error could be related to mismatching Java versions between the agent and the orchestrator. Please confirm matching Java versions. It because it is recommended that the JDK versions match up between the orchestrator and the agent.  To check this run the following from the command line:

java -version

It's always a best practice to keep the Java versions between integrated systems identical.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >