"Primer Authentication Failure" error occurs while upgrading agents from 12.9 to 14.0 SP1 using the Infrastructure Deployment Wizard.

Document ID:  TEC1460914
Last Modified Date:  06/20/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Client Automation

Releases

  • CA Client Automation:Release:14.0 SP1

Components

  • DESKTOP AND SERVER MANAGEMENT:DTSVMG
  • CA Asset Management:TNGAMO
  • CA Remote Control:TNGRCO
  • CA Software Delivery:TNGSDO
Issue:

"Primer Authentication Failure" error occurs while upgrading agents from 12.9 to 14.0 SP1 using the Infrastructure Deployment Wizard.

The logs show the following:

 

TRC_CF_DMDEPLOY log 

290517-08:24:01.2713277L|006328|00001b50|DMDeploy |DmDeploy |cdmdeployer.cpp |008529|ERROR | Error establishing TLS connection with Primer. Error code: 10 

290517-08:24:01.2714438L|006328|00001b50|DMDeploy |tlsauthent |etpkiimp.cpp |000209|DETAIL | Deleted ETPKI-TLS instance 01541000 

290517-08:24:01.2714775L|006328|00001b50|DMDeploy |DmDeploy |cdmdeployer.cpp |002816|ERROR | Error setting up TLS session with the target primer! 

290517-08:24:01.2715029L|006328|00001b50|DMDeploy |DmDeploy |cdmdeployer.cpp |001065|INFO | RequestPrimerAuth unknown return code (rc = 10) 

 

DMPrimer.log on the Agent 

05/29/17 08:24:00 | 6556 | 10780 | tlswrapper.cpp | 100 | ETPKI Path: C:\Program Files (x86)\CA\DSM\DMPrimer\cryptocme2.dll 

05/29/17 08:24:00 | 6556 | 10780 | tlswrapper.cpp | 135 | Error allocating the TLS security context. Return code: 0x8000ffff 

05/29/17 08:24:00 | 6556 | 10780 | cdmprimer.cpp | 7735 | Error initializing the client TLS instance. Return code: 10 

05/29/17 08:24:00 | 6556 | 10780 | ccam.cpp | 627 | Sending type DSM_2_DMP_TLS_INIT to CAM queue CAI006328-00021 on machine AGENTABC. 

Environment:
CA Client Automation Version - 14.0 SP1
Cause:

This error may happen if the Primer version installed on the agent is from an older/incompatible ITCM build.

The best solution is to uninstall the Primer on the target and try the deployment again.

 

1. Deploy an Asset Management/Software Delivery job to uninstall dmprimer using the command:

MsiExec.exe /X {A312C331-2E7A-42E1-9F31-902920C402EE} /qn /norestart 

 

2. Try the upgrade again using the Deployment Wizard.

(OR)

Upgrade the agent using the Software Delivery Agent package.

 

 

Resolution:

Uninstall Primer

Deploy

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >