Unable to delete attachments in a field where the user has sufficient access rights (Create, Edit All and Navigate access rights)

Document ID:  TEC1454295
Last Modified Date:  07/17/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA PPM

Releases

  • CA PPM:Release:14.4
  • CA PPM:Release:15.1
  • CA PPM:Release:15.2

Components

  • CA PPM SAAS STUDIO INTERNAL ONLY:ODSTU
  • CA PPM STUDIOINTERNAL ONLY:PPMSTU
Issue:

Attachments cannot be deleted even if the user has sufficient access rights (Create, Edit All and Navigate access rights).

Steps to Reproduce:

  1. Create a custom object which has an attachment attribute
  2. Create an instance for this custom object
  3. Add the global access rights(Create, Edit All and Navigate access rights)for this custom object to a user
  4. Log in with the user and navigate to the instance
  5. Attempt to delete the attached file in the instance

Expected Result: The user should be able to delete the attached file.

Actual Result: The user is not able delete the attached file and receives an error.

Environment:
This issue affects CA PPM v14.4, v15.1 and v15.2.
Cause:

This issue has been reported as CLRT-80953/DE29593.

Resolution:

Sustaining Engineering has fixed this issue in CA PPM v15.3 and has backported the fix to v15.1 patch 6 and v15.2 patch 2.

Workaround:

Add the "Object - Administration" right.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >