CA PROCESS AUTOMATION: Queued Processes

Document ID:  TEC1390826
Last Modified Date:  12/06/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Process Automation

Releases

  • CA Process Automation:Release:4.3
  • CA Process Automation:Release:4.3.1
  • CA Process Automation:Release:4.3.2

Components

  • Process Automation:ITPAM
Issue:

Reported Issues: Processes are going to queued state and not moving into a Running state.  

Environment:
PAM 4.3 HF01 Single Node But can impact almost any Process Automation version.
Cause:

The database was not in a good condition.

Simple query execution directly in SQL Server Manager is very slow from SQL client. 

Investigation showed this to be at least in part due to not having enough disk space in C drive and CPU utilization is near or above around ~90 all the time.

Resolution:

1.  Cleaned queued records and aborted records within Process Automation, had the DBA review and tune the database.

2.  Instead of using common DB for both Lib and Runtime, we separated the Runtime DB using the installer. 

 

 

Additional Information:

Further Recommendation: 

Plan to use PAM Cluster to improve overall throughput and provide for some redundancy and failover capability.

Add more disk space and CPU cores to DB server. 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >