TDM Portal: Scheduled job remains in Running status and does not get completed

Document ID:  TEC1373171
Last Modified Date:  08/10/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Test Data Manager

Releases

  • CA Test Data Manager:Release:4.1

Components

  • CA Test Data Manager - TDM Web Portal:TDMWBP
Issue:

We want to be able to schedule a specific job to run each day to generate data for the QA Testers for that specific day.  To try and remember to do that each precedent night is prone to errors (people forgetting, person on leave, backup person forgetting, What happens Sunday Night, etc.)  To mitigate this, we tried to schedule an entire week's worth the Friday before.  The result is that it always fails with the job hanging.  Need to be able to schedule a week in advance.

Environment:
TDM Portal 4.1
Cause:

It was discovered that the token for the job had expired as it is only valid for 24 hours in its default value of 86400 (seconds). 

Resolution:

This default value can be reset in the applications.properties file. Here is the solution: 

Changed the Token Timeout from 1 day to 100 days in the application.properties file. 

jwt.expiryInSecs=86400 

the value is in seconds so we multiplied by 100. 

jwt.expiryInSecs=864000 

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