Unable to edit or refresh some of the reports as the buttons are showing grayed out.

Document ID:  TEC1360034
Last Modified Date:  08/02/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Service Desk Manager

Releases

  • CA Service Desk Manager:Release:14.1

Components

  • SERVICE DESK BUSINESS OBJECTS:SDBOXI
Issue:

We are not able to edit or refresh some of the reports as the buttons are showing grayed out.

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Environment:
BI 4.X
Cause:

Issue happens if there are any security restrictions in accessing the report or user don't have enough permissions to run a report.

Because of which some times, reports may run only from BI launchpad and not from Rich-client or sometimes user will not be able to refresh from both BI launchpad and Rich-client.

Resolution:

Points to check

1.   Login into Central Management Console(CMC) with Administrator credentials.

2.   Navigate to Users & Groups -> Select Group List -> Right click on the group the user is member off->Customization->Features->Check if the Design Mode Feature Enabled or disabled.

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     3.    Navigate to Folder-> Navigate to the report path -> right click on the report->check user security for view permissions.6.PNG

 

p   4.   Open the report->On the File tab, Click the Save drop-down menu

b. Click Save as

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c. Check the checkbox “ Remove Document Security “

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d. Click Save

e. If you are saving in same location as in original file, Pop-up asks if you want to overwrite the file, click Yes

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5.   Log out completely from BI launch pad or Rich client. And re-login to test

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