Issue with Contacts Synchronization between ITAM and CA SAM.

Document ID:  TEC1347437
Last Modified Date:  12/07/2017
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Products

  • CA IT Asset Manager

Releases

  • CA IT Asset Manager:Release:12.9

Components

  • CA Asset Portfolio Management:ARGIS
Issue:

In an environment where ITAM and CA SAM are integrated, when we  create contacts in ITAM they are not synchronized  into SAM. Companies and Cost Centers are coming into CA SAM. This was working before and no change have been done.

Environment:
ITAM 12.9 integrated with CA SAM
Cause:

The issue was encountered due to huge number of records in arg_job_task table ~13 million.

Workaround:

We need to remove the table arg_job_task's rows for completed jobs (status='completed').

Run the script below on the mdb:

------------------------
DECLARE @BATCHSIZE INT
SET DEADLOCK_PRIORITY LOW;
SET @BATCHSIZE = 5000

WHILE @BATCHSIZE>0
BEGIN
-- IF @BSTOPATMAXTIME = 1, THEN WE'LL STOP THE WHOLE JOB AT A SET TIME...

DELETE TOP(@BATCHSIZE)
FROM arg_job_task
WHERE status='completed'

SET @BATCHSIZE=@@ROWCOUNT

END
----------------------------------

Additional Information:

The issue is fixed in ITAM 14.1

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