Performing searches with SmDmsObjects using the getAttributes() function, no results are returned.

Document ID:  TEC1312461
Last Modified Date:  08/01/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Single Sign-On

Releases

  • CA Single Sign-On:Release:12.6.1

Components

  • SITEMINDER -SDK:SMSDK
Issue:

We've run SDK custom code. and when we perform searches with SmDmsObjects using the getAttributes() function, no results are returned.

 

  2017-06-28 10:50:18,810 51 [DEBUG] 10.26.140.110 smtest 8ms SiteMinderAdapter SiteMinderAdapter[1893].search(): SiteMinderAdapter.search() - SmDmsUser: 

  2017-06-28 10:50:18,810 51 [DEBUG] 10.26.140.110 smtest 8ms SiteMinderAdapter SiteMinderAdapter[1893].search(): Attributes = {} 

  2017-06-28 10:50:18,811 51 [DEBUG] 10.26.140.110 smtest 12ms SiteMinderAdapter ReadUser[154].execute(): ReadUser.execute() - SmDmsUser: 

  2017-06-28 10:50:18,811 51 [DEBUG] 10.26.140.110 smtest 12ms SiteMinderAdapter ReadUser[154].execute(): Attributes = {} 

 

The same code with the same User Store and settings in 12SP3 was

returning attributes values. How can we fix this problem ?

 

Environment:
Policy Server 12.6.01 on RHEL 6.7 x64 SDK 12.6.01 (Java) on RHEL6.7 User Store on CA Directory R12 SP5 (build 12858) Linux 64-Bit java version 1.8.0_101 64bit
Resolution:

This issue is expected to be fixed in 12.7CR01

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >