The DerbyDialect dialect has been deprecated; use one of the version-specific dialects instead

Document ID:  TEC1294093
Last Modified Date:  06/15/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Service Virtualization

Releases

  • CA Service Virtualization:Release:10.0
  • CA Service Virtualization:Release:10.1.0

Components

  • CA ITKO LISA Virtual Services Environment (VSE):ITKOVS
  • CA ITKO LISA TEST / FRAME:ITKOTF
Question:

Why does this WARN message appear in the Enterprise Dashboard log file?

WARN org.hibernate.dialect.DerbyDialect - HHH000430: The DerbyDialect dialect has been deprecated; use one of the version-specific dialects instead 

Environment:
DevTest 10.0 DevTest 10.1
Answer:

This WARN message happens when the Enterprise Dashboard is configured with Apache Derby.

Apache Derby is provided as an out-of-the-box database so that you have a functioning system as you prepare to move to the enterprise database solution for your organization. Derby is not supported as an enterprise database solution - Database Administration.

This warning doesn't happen when DevTest components are configured with an external database - External Enterprise Dashboard Database Configuration and External Registry Database Configuration.

 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >