Transport Failed Message in Broker Log

Document ID:  TEC1288807
Last Modified Date:  06/09/2017
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Products

  • CA Continuous Application Insight
  • CA Service Virtualization

Releases

  • CA Continuous Application Insight:Release:10.0
  • CA Continuous Application Insight:Release:7.1
  • CA Continuous Application Insight:Release:7.5.0
  • CA Continuous Application Insight:Release:7.5.1
  • CA Continuous Application Insight:Release:7.5.2
  • CA Continuous Application Insight:Release:8.0.0
  • CA Continuous Application Insight:Release:8.0.1
  • CA Continuous Application Insight:Release:8.0.2
  • CA Continuous Application Insight:Release:8.1
  • CA Continuous Application Insight:Release:8.2
  • CA Continuous Application Insight:Release:8.3
  • CA Continuous Application Insight:Release:8.4
  • CA Continuous Application Insight:Release:9.0
  • CA Continuous Application Insight:Release:8.5
  • CA Continuous Application Insight:Release:9.1
  • CA Continuous Application Insight:Release:9.5
  • CA Continuous Application Insight:Release:9.5.1
  • CA Service Virtualization:Release:10.0
  • CA Service Virtualization:Release:10.1.0
  • CA Service Virtualization:Release:7.1
  • CA Service Virtualization:Release:7.5.0
  • CA Service Virtualization:Release:7.5.1
  • CA Service Virtualization:Release:7.5.2
  • CA Service Virtualization:Release:8.0.0
  • CA Service Virtualization:Release:8.0.1
  • CA Service Virtualization:Release:8.0.2
  • CA Service Virtualization:Release:8.1
  • CA Service Virtualization:Release:8.2
  • CA Service Virtualization:Release:8.3
  • CA Service Virtualization:Release:8.4
  • CA Service Virtualization:Release:8.5
  • CA Service Virtualization:Release:9.0
  • CA Service Virtualization:Release:9.1
  • CA Service Virtualization:Release:9.5
  • CA Service Virtualization:Release:9.5.1

Components

  • CA ITKO LISA PATHFINDER:ITKOPF
  • CA ITKO LISA Virtual Services Environment (VSE):ITKOVS
Issue:

The Broker log is full of Transport failed -  Channel was inactive for too long messages.

Message Example:
INFO: Transport failed: java.io.EOFException
com.itko.activemq.broker.TransportConnection serviceTransportException
INFO: Transport failed: com.itko.activemq.transport.InactivityIOException: Channel was inactive for too long: /xxx.xxx.xxx.xxx:aaaaa

Where: xxx.xxx.xxx.xxx:aaaaa is an IP and port combination.

Environment:
All supported DevTest platforms.
Cause:

When starting the broker, a few of these messages is normal.
However, several thousand messages indicate the broker recovering from a corrupt solr cache.

Resolution:

Allow the broker to process these messages.
Looking closely at the messages one or more IP addresses will be listed.
For each IP address, the broker will set through the port numbers in order.

Depending on your environment and the number of database entries, this process could take a few minutes to several hours to complete.

Once completed, the messages will stop and the broker should operate as expected.

Additional Information:

Not applicable.

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