ALM Service Fault Code 203 Error When Logging into the GT HP ALM Service Connector in Agile Requirements Designer

Document ID:  TEC1288018
Last Modified Date:  07/11/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Agile Requirements Designer

Releases

  • CA Agile Requirements Designer:Release:2.5
  • CA Agile Requirements Designer:Release:2.4
  • CA Agile Requirements Designer:Release:2.3
  • CA Agile Requirements Designer:Release:2.2
  • CA Agile Requirements Designer:Release:2.1
  • CA Agile Requirements Designer:Release:2.0
  • CA Agile Requirements Designer:Release:1.9.5
  • CA Agile Requirements Designer:Release:1.9.4
  • CA Agile Requirements Designer:Release:1.9.3
  • CA Agile Requirements Designer:Release:1.9.2
  • CA Agile Requirements Designer:Release:1.9.1
  • CA Agile Requirements Designer:Release:1.9

Components

  • CA Test Case Optimizer:ITKOTC
Issue:

When using the GT HP ALM Service Connector in Agile Requirements Designer, I am receiving the following error message: ALM Service Fault received. ALM service reported the following error: Service call:startSession. Error message:Fault code 203: Error transferring http://<ServiceAddress>:8095- server replied: Not Found

 

Steps to Reproduce:

1. Enter in ALM URL and Service Address into the ALM Service Config Editor. Verify connection details are valid.

alm config editor service configuration.PNG

ALM URL is accessible.png

2. Start ALM Service. Verify it is running.

startalmservice.PNG

alm service running.PNG

3. In Agile Designer, click on the GT HP ALM Service Connector option.

gt hp alm serivce connector.PNG

4. In the Connectors Dock, click on the Login button.

connector dock.PNG
view is disabled login.PNG

5. Login to ALM using the Service Address URL. Hit the OK button.

login to gt hp alm service.PNG

Result:

fault code 203 alm error.png

Environment:
CA Agile Requirements Designer (ARD)- Agile Designer and the GT HP ALM Service (installed with CA Test Data Manager)
Cause:

The Service Address being used in Agile Designer when logging into ALM is incorrect. Assuming the service base address is set to http://*:8095/ or http://ServerName:8095/ (either is valid) in the ALM Service Config Editor, the address we should use in Agile Designer should be http://ServerName:8095/ALMService

 

Below is further documentation on using the GT HP ALM Service with Agile Designer:

 

Resolution:

To resolve this issue you need to verify that you are using the correct URL in the GT HP ALM Service Connector login window and in the ALM Service Configuration Editor. To see what GT HP ALM Service URL and Service Address you need to be using, please do the following:

 

  1. Copy the Service Address from the ALM Service Config Editor. It should look like this: http://ServiceName:8095/ 

  2. On the machine that you have ARD installed on, open a browser. 

  3. Paste the Service Address into the browser.
    • If your Service Address in the config editor says http://*:8095/, then use the server name rather than the star in the browser.
    • You do not need to change it in the config editor.
    • For example, http://*:8095/ in the config editor would be http://servername:8095/ in the browser.

  4. You will be taken to the 'ALMService Service' page. 

  5. Click link next to 'svcutil.exe'. 

    almservice service in browser.png

  6. You will be taken to a page with XML. Scroll down and find the <wsdl:service name="ALMService">. 

  7. Under this you should see a soap address like <soap:address location="http://test.test.ca.com:8095/ALMService"/>. This is the URL you need to use for the GT HP ALM Service URL inside ARD when logging into the GT HP ALM Service connector. 

    soap address alm.png

 

Now that you know the correct Service Address to use in ARD, follow the steps below to finish setting up the GT HP ALM Service configuration and login process:

 

  1. Go to the ALM Service Configuration Editor. By default, this is located at C:\Grid-Tools\GTHPALMService\GTHPALMService_ConfigEditor\ALMServiceConfigEditor.exe when you install TDM.

    alm service config editor file path.PNG


  2. In the 'Service Configuration' tab, you need to verify you are using the correct 'ALM URL' format and the correct 'Service Address' URL. 
  3. Click the 'Save' button to save your changes.

  4. Click the 'Verify' button and check the message box for any error messages. The ALM URL should be accessible. 

    ALM URL is accessible.png

  5. In the same window, click on the 'Status' tab. 

  6. You may need to create a task and enable group policy at this point if you have not previously configured this.
  7. Click the 'Start Service' button. If already running, stop the service first, then restart it.
  8. Check the message box for any errors. The GT ALM Service should be running. 

    alm service running.PNG

  9. Launch Agile Requirements Designer. 

  10. Under the 'Project' window on the left hand side of the screen, click on the 'Connectors' tab to expand all the options. 

  11. Click on the 'GT HP ALM Service' connector. 

    gt hp alm serivce connector.PNG

  12. Under the 'Connectors Dock' on the right hand side on the screen, you will see a message of 'This view is disabled - please login to ALM'. Click the 'Login' button.

    connector dock.PNG
    view is disabled login.PNG

  13. In the 'Log In To ALM' window, enter the following information, and click the 'OK' button once done.
    • GT HP ALM Service URL: http://ServiceName:8095/ALMService (You will have the /ALMService in this URL, but not in the Configuration Editor)
    • User Name
    • Password
    • Click the 'Remember password' check box.

      correct gt alm serivce connector login url.PNG


  14. If successful, you will not see an error message and be prompted to choose your 'Domain' and 'Project' for your ALM instance. 

    domain and project alm.png
  15. Once completely logged in, you will see your ALM projects in the 'Connectors Dock' on the right hand side of the screen.
Additional Information:

If you are still experiencing issues, please open a support case by going to https://support.ca.com/irj/portal/anonymous/newhome or calling support at one of these numbers http://www.ca.com/us/services-support/ca-support/contact-support.html

 

We also recommend checking out our online knowledge base for other errors/resolutions, Q&A, and how-to documents: https://www.ca.com/us/services-support/ca-support/ca-support-online/support-by-product/ca-agile-requirements-designer.html?d=t&type=Knowledge 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >