Upgrading from APM 10.1 to 10.5.1 fails.

Document ID:  TEC1258782
Last Modified Date:  08/02/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Application Performance Management

Releases

  • CA Application Performance Management:Release:10.0
  • CA Application Performance Management:Release:10.1
  • CA Application Performance Management:Release:10.2

Components

  • WILY CEM:APMCEM
  • INTROSCOPE:APMISP
  • COMMUNICATION SERVICE PROVIDER EXTENSION:INTCSP
Problem:

The APM database fails to upgrade from APM 10.1 to 10.5.1.

Introscope_10.5.1.8_InstallLog.log shows following ERROR.
Upgrade Database Schema Failed
                          Status: ERROR
                          Additional Notes: ERROR - . Check /opt/CA/Introscope/install/schematools.log for more details
                         
schematools.log shows following ERROR.    
[ERROR] [main] [root] [Upgrade10_1_0_0] - Unexpected exception while upgrading
java.sql.SQLException: ORA-12899: value too large for column "APMTEST"."APPMAP_ATTRIBS"."VALUE" (actual: 1485, maximum: 1024)

Environment:
APM is installed with Oracle Database.
Cause:

 The failure is caused by the column length of a table in APM 10.1 Database.

Workaround:

As a workaround prior to the upgrade, increase the column length manually:

 

alter table APMTEST.APPMAP_ATTRIBS modify (VALUE VARCHAR2(2048));

This command will then confirm the change:

desc APMTEST.APPMAP_ATTRIBS

 

Run the install again to upgrade the APM Database.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >