CA NFA DNS/SNMP Proxies will not start on my NFA Harvester.

Document ID:  TEC1247393
Last Modified Date:  08/04/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Network Flow Analysis

Releases

  • CA Network Flow Analysis:Release:9.3.6
  • CA Network Flow Analysis:Release:9.3.5
  • CA Network Flow Analysis:Release:9.3.3
  • CA Network Flow Analysis:Release:9.3.2
  • CA Network Flow Analysis:Release:9.3.1
  • CA Network Flow Analysis:Release:9.3
  • CA Network Flow Analysis:Release:9.2.1
  • CA Network Flow Analysis:Release:9.2
  • CA Network Flow Analysis:Release:9.1

Components

  • NQRPTA - REPORTERANALYZER:NQRPTA
Issue:

After installing/upgrading NFA I cannot start the "CA NFA DNS/SNMP Proxies" service.

 

The <Install Dir>\CA\NFA\Netflow\Logs\proxies-wrapper.log file will show an error like:

Error: com.sun.xml.internal.ws.server.ServerRtException: Server Runtime Error: java.net.BindException: Address already in use: bind

 

Environment:
NFA All Versions
Cause:

NFA uses port 8081 for this service, if another application such as MacAfee is also using this port it will prevent the service from starting.

Resolution:

You can change the port number that this service uses on each Harvester server to a port that is available such as 8089 by following the respective steps below for your version of NFA.

 

NFA 9.3.3 and earlier:

1. Open a command prompt on the Harvester and type:

mysql polller

2. Then update the port number by running:

Update settings set value = '8089' where name='SnmpProxyPort';

3.  Attempt to start the service again and it should start.

 

NFA 9.3.6 and later:

1. Open a command prompt on the Harvester and type:

mysql harvester

2. Then update the port number by running:

Update settings set value = '8089' where name='SnmpProxyPort';

3.  Attempt to start the service again and it should start.

4. On 9.3.7, once the services are running you will need to apply this patch to the console server  by following the instructions in the readme within the patch:

ftp://ftp.ca.com/pub/netqos/product_patches/NFA/9.3.7/DE307960_Router_DNS_patch.zip 

 

 

Additional Information:

If setting the port to 8089 does not allow the service to start, please verify that this port is not also in use and pick another available port for this service to run on.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >