After doing robot update 7.91 on AIX system some probes stop working such as db2 probe. Why?

Document ID:  TEC1245354
Last Modified Date:  08/04/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Unified Infrastructure Management

Releases

  • CA Unified Infrastructure Management:Release:8.47
  • CA Unified Infrastructure Management:Release:8.42
  • CA Unified Infrastructure Management:Release:8.4
  • CA Unified Infrastructure Management:Release:8.41
  • CA Unified Infrastructure Management:Release:8.51
  • CA Unified Infrastructure Management:Release:8.5

Components

  • UNIFIED INFRASTRUCTURE MGMT:CAUIM
  • UIM - ROBOT:UIMROB
Symptoms:

After upgrading an AIX robot to 7.91 some probes stopped working such as the DB2 probe.

Why is this happening and how do we correct it?

 

Environment:
UIM 8.X robot update 7.91 & 7.90
Cause:

The robot update improperly on AIX systems over writes the LIBPATH variable to: .:robot/lib:$NIM_ROOT/robot/lib

Workaround:

You can edit the robot_update package in the archive
and go to the shared_libs_AIX_5_64 tab
Then click on the Environment Variables tab
and remove the environment variable and save it.

You will need to manually go back to all AIX machine and update the environment variable LIBPATH
to the value it was before the update.

 

pic1.JPG

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >