Starting for the first time CA Scheduler task on a partition, it can abnormally end with error message CACM632E - MCPU=NO,BUT MCPU WORKLOAD DETECTED.

Document ID:  TEC1240368
Last Modified Date:  07/06/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Scheduler Job Management

Releases

  • CA Scheduler Job Management:Release:11 SP02

Components

  • CA SCHEDULER MVS:SCHDMS
Issue:

Starting Ca Scheduler task for the first time on a partition, after having duplicated it from the Scheduler environment of a different lpar (i.e. for Disaster Recovery procedure), it can abnormally end with the following error message:

 

CACM632 MCPU=NO, BUT MCPU WORKLOAD DETECTED, SCHEDULER IS SHUTTING DOWN

 

What is wrong, and how do I correct it?

Environment:
CA Scheduler 11.0
Cause:

In the CA Scheduler 11.0 SP02 Message Guide we provide the following error description:

 

CACM632 MCPU=NO, BUT MCPU WORKLOAD DETECTED, SCHEDULER IS SHUTTING DOWN

Reason: The CAS9 CAIJGEN options indicate that CA Scheduler is in a single system

environment, but the active workload has entries for multiple SYSIDs. CA Scheduler shuts

down.

Action: Update the CA Scheduler options to indicate MCPU=YES.

 

This is an error message that causes and abnormal termination of CA Scheduler and the suggested action is not always applicable to solve the problem when the task configuration only allows MCPU=NO. 

Resolution:

Every time CA Scheduler is started, it reads the active workload for schedules that belong to the local CA Scheduler. If MCPU=NO, this is all schedules, while, for MCPU=YES, this is schedules with the local system's SYSID.

So, this error occurs when the SYSID value found on the CPU record in the active workload is not the same as the current SYSID of the lpar where the new task has been started and this can be a consequence of the fact that the new Scheduler DB has been generated by copying it  from the DB of another Scheduler running on a different lpar (different SYSID value stored in the active workload – CAIJTRK)

 

To bypass this problem, we suggest one of the following resolutions:

1.  Run the following job: 


// EXEC CAJUTIL0 
//SYSIN DD * 
ALTER SYSID FROM=xxxx,TO=yyyy 
//* where xxxx is the old SYSID and yyyy is the new SYSID. 

to override the SYSID value into the new DB with the new lpar System ID and restart CA Scheduler 
 

2.  Do a FORMAT CAIJTRK to empty out the active workload if you are willing to clear out all outstanding jobs and restart Scheduler.

Please be aware that this command wipes out your workload and therefore you will lose all active and backlogged schedules/jobs. An AUTOSCAN will be necessary to bring in the new workload. 

 


If, after this message, CA Scheduler doesn’t start correctly, please open a Case with CA Support.

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