CA ACC installation fails with a "osb_full_bundle.tar.gz.bad" message.

Document ID:  TEC1187303
Last Modified Date:  06/30/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Application Performance Management

Releases

  • CA Application Performance Management:Release:10.0
  • CA Application Performance Management:Release:10.1
  • CA Application Performance Management:Release:10.2
  • CA Application Performance Management:Release:10.5
  • CA Application Performance Management:Release:10.3
  • CA Application Performance Management:Release:10.5.1
  • CA Application Performance Management:Release:10.5.2

Components

  • APPLICATION PERFORMANCE MANAGEMENT:WLYAPM
  • COMMUNICATION SERVICE PROVIDER EXTENSION:INTCSP
  • INTROSCOPE:INTSCP
  • INTEGRATION INTROSCOPE FOR SPECTRUM:INTSPC
  • WILY INTROSCOPE:APMINT
Problem:

 

Adding custom bundle to CA APM Comand Center fails with the below message. 

Followed the steps on the page https://docops.ca.com/ca-apm/10-5/en/implementing-agents/build-and-manage-agents/add-custom-bundles to add a OSB to the WebLogic agent v10.5.0.1

However, I get the error below in the APM Command Center Server log:

2017-05-25 10:37:30.043 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=metadata/
2017-05-25 10:37:30.044 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=metadata/description.md
2017-05-25 10:37:30.047 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=metadata/osb-full.bundle
2017-05-25 10:37:30.047 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=metadata/installInstructions.md
2017-05-25 10:37:30.048 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/
2017-05-25 10:37:30.049 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/
2017-05-25 10:37:30.049 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/ext/
2017-05-25 10:37:30.050 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/ext/examples.pbd
2017-05-25 10:37:30.050 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/config/
2017-05-25 10:37:30.051 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/config/OSB.pbd
2017-05-25 10:37:30.052 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/config/OSB-toggles-full.pbd
2017-05-25 10:37:30.055 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/config/bundle.profile
2017-05-25 10:37:30.056 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : this.profileFragmentLines=[#<preamble>, # This is the preamble for OSB full instruction bundle, # Any line without a leading # will be read as a property by the agent. Please make sure property values are unique across all bundles, #</preamble>, , #<property>, # This describes the following property mybundle, #</property>, mybundle.enable=true]
2017-05-25 10:37:30.057 INFO 97876 [taskScheduler-1] --- .c.s.BundleServiceImpl$BundleMetaBuilder : bundleArchive.getName()=wily/core/config/OSB-full.pbl
2017-05-25 10:37:31.274 ERROR 97876 [taskScheduler-1] --- c.c.a.a.c.c.services.BundleServiceImpl : Invalid directory 'wily/' for bundle={name:osb-full, version:10.5.0.0, path:osb_full_bundle.tar.gz}. Only 'directives', 'lib' and 'metadata' directories are allowed. check bundle ./import/osb_full_bundle.tar.gz.bad

Environment:
APM 10.x
Cause:

 

In metadata/osb-full.bundle, the property "specificationVersion" must be "1" not "2" .
If the bundle is in the old "wily" format. Therefore you get the error message "Only 'directives', 'lib' and 'metadata' directories are allowed":
those directories are in the new "gae" packaging format.

Workaround:

 

 Try setting metadata/osb-full.bundle the property "specificationVersion" value to 1.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >