I am receiving a List packages failed message in the log when refreshing my repository in CA Development Environment for z Systems (CA DEz).

Document ID:  TEC1054745
Last Modified Date:  09/28/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Development Environment for z Systems

Components

  • CA DEVELOPMENT ENVIRONMENT FOR Z SYSTEMS:MFDEVZ
Issue:

I am receiving a List packages failed message in the log when refreshing my repository.

Full message is: 

java.lang.NullPointerException 

at com.fasterxml.jackson.core.JsonFactory.createParser(Unknown Source) 

at com.fasterxml.jackson.databind.ObjectMapper.readValue(Unknown Source) 

at com.ca.endevor.service.ProcessedActionResponse.<init>(Unknown Source) 

at com.ca.endevor..jobs.packages.ListPackagesJob.run(Unknown Source) 

at org.eclipse.core.internal.jobs.Wroker.run(Unknown Source) 

Resolution:

Steps to recreate:

 

Start DEz

Open Endevor SCM perspective

Create a repository

Add a project to the repository

From the package view tab click create package icon

Enter package details & click finish

view the Endevor SCM log file

 

This is the same error I get when I create/refresh the repository in the log.

My problem is resolved.  It appears I had an incorrect Web Service URL.

I am now working fine.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >