Process based on subobject doesn't start even though the start condition is met.

Document ID:  TEC1041718
Last Modified Date:  06/08/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA PPM

Releases

  • CA PPM:Release:15.1

Components

  • CA PPM SAAS BUSINESS PROCESS MANAGEMENT INTERNAL ONLY:ODBPM
  • CA PPM BUSINESS PROCESS MANAGEMENT INTERNAL ONLY:PPMBPM
Problem:

Process based on subobject with Start Condition including a virtual attribute does not auto-start.

Steps to Reproduce:

Example: Task object ( subobject of Investment) with wbsort attribute (virtual attribute)

1. Create a process where the primary object is the task object
2. Auto start condition: Task WBS Sort != Task WBS Sort [Previous Value]
3. Link the start and finish steps and validate and activate the process
4. Create a project and a few tasks.
5. Add the WBS Sort attribute to the task list view and note the values for the WBS Sort attribute
6. Open the project in Gantt PPM
7. Drag and drop the tasks in order to change the order to the tasks.
8. Go back to the task list and notice the WBS Sort attribute value has changed.
9. Open one of these tasks where the value has changed and get to the processes tab

Expected Result:  

The process has initiated because the start condition is met

Actual Result:  

The process does not auto-start.

Cause:

Caused by DE29600

Resolution:

Won’t Fix

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >